Adblock Plus, Greasemonkey For Firefox 3 Beta 5


I love Adblock Plus – I refuse to use the internet without it. I also quite enjoy Greasemonkey. Unfortunately, neither is yet compatible with the new Firefox 3b5. I got tired of waiting so I took measures into my own hands.

The XPI file format is basically a glorified zip file, so you can unzip it with a compression utility and modify the maximum version number in install.rdf. Basically I replaced the value in the em:maxVersion field with 3.* so to make it compatible with all versions of Firefox.

Of course, these maximum version numbers are there for a reason: newer versions of Firefox may break the extension functionality, but no problems so far.

For the lazy, I have uploaded the patched install files. Of course I give zero guarantees or warranty for the correct operation of these patched extensions. I encourage you to upgrade to the official compatible version as soon as possible.

To install:

  1. Download File
  2. Drag downloaded file into open Firefox window
  3. Enjoy an Ad-free internet

Adblock Plus For Firefox 3 Beta 5 The Adblock Plus Development build now supports Beta 5. Get it here: http://adblockplus.org/devbuilds/

Greasemonkey For Firefox 3 Beta 5

, ,

  1. #1 by Andreas on April 6, 2008 - 10:21 am

    Thanks! :-)

  2. #2 by z1t0un3 on May 21, 2008 - 9:35 pm

    thx a lot

  3. #3 by exoedus on January 20, 2009 - 8:27 am

    dosenot seem to work with firefox 3.0.5.
    says greasemonkey is not compatible with firefos 3.0.5.

  4. #4 by mukesh on February 1, 2009 - 5:48 pm

    itz coolll

(will not be published)